Linux administrators urge to update their systems due to the discovery of a critical vulnerability the open source Linux-and-Windows-compatibility software Samba. The vulnerability in Samba, coded as CVE-2015-0240, affects versions 3.5.0 through 4.2.0rc4 according to a security alert published by the Samba Project. The Samba vulnerability resides in the smbd file server daemon, an attacker could exploit the flaw to execute code remotely with root privileges.
“All versions of Samba from 3.5.0 to 4.2.0rc4 are vulnerable to an unexpected code execution vulnerability in the smbd file server daemon. A malicious client could send packets that may set up the stack in such a way that the freeing of memory in a subsequent anonymous netlogon packet could allow execution of arbitrary code. This code would execute with root privileges. ” reads the desription in the alert.
The Samba vulnerability can be exploited by a malicious Samba client, by sending specially-crafted packets to the Samba server, the experts highlight that no authentication is required to exploit this bug.
Samba, which is present in nearly all Linux distributions, is a free software which implements the SMB/CIFS networking protocol to provide file and print services. Samba is also installed as a component of *BSD and OS X systems, it can integrate with Windows Active Directory and can act as a domain controller or as a domain member, Samba it popular because it allows a stable integration between Linux systems and Active Directory.
“This flaw arises because of an uninitialized pointer is passed to the TALLOC_FREE() funtion. It can be exploited by calling the ServerPasswordSet RPC api on the NetLogon endpoint, by using a NULL session over IPC.” states a detailed analysis of the vulnerability published by Red Hat. “It can result in remotely controlled execution of arbitrary code as root.”
According to the security advisory published by Red Hat, the Enterprise Linux versions 5 through 7 are affected, as well as Red Hat Storage Server versions 2.1 and 3.
Samba Organization informs that a patch to fix the security issue is already available at
Samba vendors and administrators running affected versions are invited to upgrade or apply the patch as soon as possible.
(Security Affairs – Samba, Linux)
Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.
Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.